This article may need to be rewritten to comply with Wikipedia's quality standards. You can help. The talk page may contain suggestions. (December 2013)
QtRuby
Final release
2.2.0 / December 16, 2011; 9 years ago (2011-12-16)
Repository Edit this at Wikidata
Written inRuby
Operating systemCross-platform
LicenseLGPL 2.1
WebsiteTechbase

QtRuby is a binding of the application framework Qt for Ruby. Korundum is an additional set of bindings for KDE which extend QtRuby.

QtRuby is cross-platform, as all the underlying technologies are platform agnostic.

QtRuby hello world

require 'Qt4'

app = Qt::Application.new(ARGV)

hello = Qt::PushButton.new('Hello World!')
hello.resize(200, 30)
hello.show

app.exec

The Korundum documentation[1] proposes a more "rubyish" version of this program.

Notable applications that use QtRuby

Status and maintenance

Currently, QtRuby is maintained (if at all) as part of Korundum.

A third-party implementation, named "qtbindings" in the Rubygems repository, has been made due to the lack of active development.[4] Stated goals of the project include keeping an up-to-date version of the Qt framework for Ruby, as well as improving compatibility with non-Linux systems.[5] As of December 2013, it supports Ruby 2.0 and 1.9, but not 1.8.

References

  1. ^ Development/Languages/Ruby - KDE TechBase
  2. ^ Announcing Kubeplayer
  3. ^ "Kaya Project Homepage". Archived from the original on 2012-07-24. Retrieved 2012-07-23.
  4. ^ "qtbindings / RubyGems". Retrieved 2013-12-12.
  5. ^ Melton, Ryan. "ryanmelt/qtbindings". Retrieved 2013-12-12.